WebWrapper

Создавайте свои приложения для KrassOS!

Image
Если вы не нашли на PackageGallery приложения для нужного Вам сервиса - не беда!
Вы можете сделать его сами! И для этого Вам не нужны навыки программирования.

WebWrapper
Это утилита позволяющая из любого веб-сервиса создать нативное приложение для пк под управлением KrassOS.
Image
Работает следующим образом - вы указываете

  • название приложения
  • http/https адрес сервиса
  • при необходимости устанавливаете дополнительные параметры или выбираете иконку.
Далее указанный вами сервис упаковывается в отдельный Electron контейнер средствами Nativefier, упаковывается в deb пакет и далее вы можете поделиться приложением с друзьями или установить на свой ПК. Или и то и другое =)

Для продвинутых пользователей

Если вы хотите иметь полный контроль над созданием приложения - вы можете использовать основной действующий компонент WebWrapper - Nativefier [GitHub]. Вам будет предложено установить его автоматически при первом запуске WebWrapper, или же вы можете использовать исходный код с GitHub.

Image

Установка

Если Вы используете KrassOS 2.5 или новее - просто установите WebWrapper в PackageGallery (нажмите кнопку "Установить")
Image

Установка на KrassOS Old Stable

Если вы используете более старую версию KrassOS: 

Способ №1:
Для работы с WebWrapper обновите систему до последней стабильной версии используя KrassOS Updater

Способ №2:
Установите приложение PackageGallery на Ваш ПК под управлением KrassOS более старых версий. Для этого нажмите кнопку "Скачать" и выполните установку скачанного приложения.

Способ №3:
Выполните следущие действия:
Откройте терминал (CTRL+ALT+T или пункт "Терминал" в меню KrassOS) 2. Введите (или скопируйте) следующие команды:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys FEBBF938474F8655 
sudo add-apt-repository "deb http://repo.krass-os.ru/ubuntu bionic main" 
sudo apt update 
sudo apt install webwrapper
Image
И после этого запускайте WebWrapper.

Делитесь Вашими приложениями!

Приложения созданные c помощью WebWrapper совместимы с

  • KrassOS 2.4 и новее
  • Debian 10 и новее
  • Ubuntu 18.04 и новее
  • Linux Mint 19.1 и новее
  • Elementary OS 5.0 и новее
  • Deepin Linux 15.5 и новее

Вы можете отправлять ваши приложения друзьям, а так же можете отправить их нам, для публикации в PackageGallery